Hogere PHP-versie vereist voor Pronamic iDEAL

Remco 4 oktober 2016

Bij Pronamic vinden we achterwaartse compatibiliteit (Engels: backward compatibility) erg belangrijk. De Pronamic iDEAL plugin functioneerde daarom ook nog steeds op PHP versie 5.2. Dit terwijl deze PHP versie al in 6 januari 2011 de label ‘end of life‘ heeft gekregen en dus niet meer bijgewerkt wordt. Ook worden er geen veiligheidsupdates meer uitgebracht voor deze versie. Vandaar dat we nu een hogere PHP-versie vereisen voor de Pronamic iDEAL plugin.

Waarom verhogen we de vereiste PHP-versie?

Het laten vervallen van de ondersteuning voor PHP 5.2 was niet een eenvoudig besluit. We hebben dit jaren geleden al overwogen, maar tot nu toe altijd uitgesteld. Maar we vonden het nu toch wel tijd worden om deze stap te nemen en wel om de volgende 3 redenen:

  1. Veiligheid
  2. Efficiëntere code
  3. Sneller ontwikkelen

Waarom nu?

Afgelopen jaren kwam het gebruik van oudere PHP-versies zoals 5.2 erg vaak ter sprake bij webontwikkelaars. Zo schreef Coen Jacobs begin 2015 al het “Time to update your PHP version” artikel en lanceerde hij WPupdatePHP. Veel hostingleveranciers maakten namelijk nog gebruik van verouderde PHP-versies. Zij zijn inmiddels wakker geschud en alle grotere hostingleveranciers zijn zich er bewuster van dat ze hun software up-to-date moeten houden. Ook wordt op de WordPress.org requirements pagina geadviseerd om gebruik te maken van PHP-versie 5.6 of hoger.

Blijft mijn WordPress website werken?

Ja, door deze wijziging zal je WordPress website gewoon blijven werken. De kans is namelijk groot dat je hostingleverancier gewoon werkt met PHP-versie 5.3 of hoger. Mocht je hostingleverancier toch nog werken met PHP-versie 5.2  dan zal je in Pronamic iDEAL 4.4 als beheerder in de WordPress admin omgeving de volgende melding zien:

Hogere PHP-versie vereist voor Pronamic iDEAL admin notice

Als je deze melding te zien krijgt is het verstandig om contact op te nemen met je hostingleverancier. In Pronamic iDEAL versie 4.5, welke we later dit jaar lanceren, zal de Pronamic iDEAL plugin niet meer functioneren met PHP 5.2. Je WordPress website zelf zal wel gewoon blijven functioneren.

Wat als mijn hostingleverancier nog werkt met PHP 5.2?

Alle grotere hostingleveranciers werken tegenwoordig standaard met PHP 5.3 of hoger. Mocht je je website toch ondergebracht hebben bij een hostingleverancier die alleen nog werkt met PHP 5.2 dan kun je informeren of zij PHP kunnen bijwerken naar een laatste stabiele en veilige versie:

Een plugin die ik wil gebruiken op mijn WordPress website vereist PHP 5.6. WordPress.org heeft op hun requirements pagina ook vermeld dat PHP 5.6 de aanbevolen PHP-versie is voor WordPress. Meer informatie hierover is ook te vinden op de WPupdatePHP website. Kunnen jullie mij laten weten of mijn hosting PHP 5.6 ondersteunt en hoe ik deze versie kan gebruiken? Bedankt.

Mocht dat niet mogelijk zijn dan is het verstandig om over te stappen naar hostingleverancier die betere ondersteuning geeft. Op de WordPress.org hosting pagina staan een aantal goede suggesties. Mocht je hier hulp bij nodig hebben dan kun je ook altijd contact met ons opnemen. Wij helpen je graag!

0 reacties

Reacties zijn gesloten.

Altijd op de hoogte blijven?